Create ticket via powershell fails due to invalid responder_id

@eriknettekoven I apologize, I misunderstood where you were struggling. I don’t want to waste any more of your time.
I did try to replicate your environment to the best of my ability, and sent a POST request to create a ticket using the Freshservice API and I also am seeing the same errors you are when using postman.

I have to agree with you that if the fields are not set to required for when a requester submits a ticket, then the API should allow us to indicate that the ticket is being initiated from a requester and not an agent in some fashion. I am not sure that this is feasible but @Saif would have better knowledge of where the product team sits with this functionality.

Appreciate your patience Erik, and again apologize for having you jump through so many hoops. Take care!

1 Like

@Vinoth_Christofer we need your help here. Can you please take a look? Thanks!

1 Like

@Saif @Tanmay_Kapoor Is there any update available on this?

Hi @eriknettekoven

We tried to put you in touch with the Freshservice team directly. You might have received an email to carry on a ticketed conversation. I hope that would get you the necessary help. If you find the right answers, please share them with us on this thread. It might be helpful for future community members to see this thread.

2 Likes

Hi,

tl;dr: Issue is solved by using business rules.

Explanation:
So my first hunch you can read here, turned out to be the case; Tickets created via API, will follow the behaviour rules set for agents. Which makes perfect sense, as the API is just another “form” of an agent. To not turn off these field requirements for all agents, you can use business rules to negate this requirement per agent (or per whatever you seem fit).

How:
Login to your freshservice portal with an administrative account.
Go to Admin → Business Rules For Forms → Create New Rule

Enter a name to identify the rule, and fill in the options per below screenshot

Scroll down to conditions and actions and fill in accordingly. Especially with the Actions is where the magic happens:

The above business rule is currently set to not require a group and agent when a ticket is created using my account (via the portal or via API).

Our next challenge is to create a special agent account, that is not tied to a specific person, but we will figure something out.

By the way, I was pointed to this solution by the Freshdesk service desk, which described in detail how things worked and how to setup the business rule! Thank you all for taking the time to troubleshoot this issue.

I do want to recommend to get some sort of note in the API V2 documentation, regarding the above. :sweat_smile:

3 Likes

Hey @eriknettekoven great to hear you found a solution. I appreciate the detailed explanation! Looks like we could leverage this in a few different ways. :muscle:
Take care!

1 Like