Failed to fetch installation parameters

I am trying to install an app on a new server I am testing on, however, I cannot seem to fetch the installation parameters:

I have the following iparams.json file within my app/config/ directory:

{
  "apiKey": {
    "display_name": "YouTrack Permanent token ",
    "description": "Please enter your YouTrack token",
    "type": "api_key",
    "secure": true,
    "required": true,
    "type_attributes": {
      "product": "freshdesk"
    }
  },
  "api_key": {
    "display_name": "Freshdesk apikey",
    "description": "freshdesk API requires app calls to include API keys in all of their requests",
    "secure": true,
    "type": "text",
    "data-bind": "product.api_key",
    "required": true
  },
"creatorDomain": {
    "display_name": "Who is creator of Ben 10 cartoon series",
    "type": "domain",
    "description": "devrel",
    "data-bind": "product.domain",
    "type_attributes": {
      "product": "freshdesk"
    }
  }
}

I have attached the latest fdk.log and HAR file:
fdk.log (141.6 KB)
InstallParamsIssue.har (551.8 KB)

If you need any further details/information please let me know.

@Ayoub_Sebtane
Good Day! Welcome to the community!

you need to add the config directory outside of the app directory,
eg:

you can verify the sample apps for more reference :slight_smile:

and the Iparams which you added won’t allow you to pass the validation.

modlify it as like below :point_down:

{
  "apiKey": {
    "display_name": "YouTrack Permanent token ",
    "description": "Please enter your YouTrack token",
    "type": "text",
    "secure": true,
    "required": true,
  },
  "api_key": {
    "display_name": "Freshdesk apikey",
    "description": "freshdesk API requires app calls to include API keys in all of their requests",
    "secure": true,
    "type": "api_key",
    "data-bind": "product.api_key",
    "required": true,
    "type_attributes": {
      "product": "freshdesk"
    }
  },
"creatorDomain": {
    "display_name": "Who is creator of Ben 10 cartoon series",
    "type": "domain",
    "description": "devrel",
    "required": true,
    "data-bind": "product.domain",
    "type_attributes": {
      "product": "freshdesk"
    }
  }
}

FYI: api_key and domain type is only allowed for freshworks products and not for third party

Hope it helps :slight_smile:

Thanks

Hi,
I also tried this with the config/ directory outside of the app/ directory, as you have detailed.
I have tried replacing the contents of my iparams.json with the contents you have displayed above but I am still experiencing the same issue. Do you know what else I can try?
Thanks

@Ayoub_Sebtane,
Have you tried with the above mentioned sample apps?
or try create the app with fdk create, this will give you the predefined template.
and you can try changing the Iparams.json with the above mentioned values and test it.
and if you are still facing issue, kindly share us the app.zip, we will try to find the root cause for your problem!

Thanks

Hi @Santhosh
I have tried creating a new app, via fdk create, and then using the iparams.json you suggested but I still receive the same response.
I have attached my app.zip for you to look at.
I really appreciate your help!
app.zip (56.0 KB)

@Ayoub_Sebtane,
Good Day!
Seems like the app.zip contains specific files,
Can you please share us the complete app, so that we can investigate what is wrong!

Thanks

Hi @Santhosh ,
Apologies, I have now uploaded a zip of all the files & folders in my directory that contains the previous app.zip folder & files
Let me know if you need anything else.
Thanks!
full_app.zip (4.3 MB)

@Ayoub_Sebtane,
I had verified your app in my test system and I am able to see the Iparams (settings) when I run fdk run command.
can you please make sure you are having the latest fdk with you?
I am using version 7.4.1
if you are having old then try to upgrade to the latest version and try fdk run?

Thanks

Hi @Santhosh,
Thank you for the suggestion but it is still not working.
I upgraded fdk to 7.4.1 (and also npm to 8.5.2), but I am still receiving the same issue.
Do you know what else I can try?
Thanks

can you try remove items under .fdk folder and try fdk run?
location of .fdk folder is under home folder

Thanks

Hi @Santhosh,
I have tried this and still the same result

Could it be an issue with my IP being blocked by freshdesk or something, as I had this app working on my local machine before trying to migrate across to the server I am trying to run on now?

@Ayoub_Sebtane,
Seems like that could not be an issue!

Can you schedule an office hours meeting with us using the following Calendly link to debug what is wrong? since we could not able to identify with the logs and the code sample which you shared with us

Thanks

I have scheduled this in.
Thank you for your help @Santhosh

1 Like

Hello @Santhosh,

Thank you for your help so far.
I am trying to now run my app locally as you suggested.
I am having trouble configuring the iparams though, as when setting the custom configs, I am receiving the error “Domain or API key is not matching” for my “Youtrack Permanent token” & “creatorDomain”.
I have created a new YT token on my server and updated this throughout my app: service-config.properties.
I cannot find any mention of the domain to set here, and I am unable to input the URL I have previously been using: https://support.featurespace.com/a/tickets/3423?dev=true

Can you provide assistance on what I’m doing wrong here please? :slight_smile:
For reference I am using the following iparams.json file, as recommended previously:

{
  "apiKey": {
    "display_name": "YouTrack Permanent token ",
    "description": "Please enter your YouTrack token",
    "type": "text",
    "secure": true,
    "required": true,
  },
  "api_key": {
    "display_name": "Freshdesk apikey",
    "description": "freshdesk API requires app calls to include API keys in all of their requests",
    "secure": true,
    "type": "api_key",
    "data-bind": "product.api_key",
    "required": true,
    "type_attributes": {
      "product": "freshdesk"
    }
  },
"creatorDomain": {
    "display_name": "Who is creator of Ben 10 cartoon series",
    "type": "domain",
    "description": "devrel",
    "required": true,
    "data-bind": "product.domain",
    "type_attributes": {
      "product": "freshdesk"
    }
  }
}

@Ayoub_Sebtane ,
Good Day! sorry for the delay in responding

can you please check the API and domain name is valid?
and the API key and domain name should be your freshdesk API key and domain name.

Thanks

Hi @Santhosh
Thank you for your reply!

How would I check if the API & domain name is valid?
I believe I have entered the API key & domain name as my Freshdesk API key & domain name I am using for testing.

Could we perhaps schedule a call to go through this as I am not sure what the issue is here, or how to test it further?

Thanks,
Ayoub

Hi,
you can schedule office hours meeting with us using the following Calendly link .

Thanks

To conclude the issue,

We couldn’t see the issue happening when the troubleshooting call happened. The issue got resolved and we don’t know why it wasn’t working before.

1 Like