FDK validate OK , FDK build not work

Hello,

I’m following a post I had already created No Error , Not possible fdk pack?

I am currently still developing my application. but this one gives me the same problem again. unable to build app…

I had found a trick to get around this problem as indicated in my previous post, but this one no longer works…

however, I have no error when I run fdk verify
image

when I run fdk pack , it ends without creating the file
image

can you help me ? I have to deliver my application quickly :’(

FDK Version : 7.5.0
node.js 12.22.0
plateforme-version 2.2

Thank you !

fdk build log.txt (33.7 KB)

Hi @aliweb88, I do not see anything specific error in the log file that you have attached. I see a lot of warning messages around code complexity and out-of-scope assignment.

I see in the previous topic (No Error , Not possible fdk pack? - #9 by aliweb88) you have mentioned that you had to delete the app/scripts folder to get fdk to pack successfully. I am not sure if that is an acceptable solution if your apps depend on the scripts in app/scripts.

Can you try the following and tell me what you see:

  1. Remove the .fdk/ directory in the app’s main directory and try running fdk pack again.
  2. Try updating to the latest FDK 8 and re-run fdk validate and fdk pack and share the log file. Given that FDK 7 will be deprecated soon, we will not be able to provide any fixes to the FDK 7 branch.

Hello @kaustavdm

Thanks for help !

I already tried this method, I deleted .fdk and app/scripts. when I run fdk pack . I have the same result, except that it regenerates all the deleted files.

Here is the information from fdk.log after running and deleting .fdk and app/script:

2022-05-11 14:05:40.010 +0200 [debug] (e[34mlogger.jse[0m) e[31mStarting FDK in node v12.22.0 on win32e[0m

2022-05-11 14:05:41.784 +0200 [debug] (e[34msequelize.jse[0m) e[31msetting up sqilite at "C:\laragon\www\extentionFreshDesk/.fdk/store.sqlite"e[0m

2022-05-11 14:05:42.004 +0200 [debug] (e[34mindex.jse[0m) e[31mRunning with args {“cmd”:“pack”,“gopts”:{},“opts”:{},“goptArg”:{},“optArg”:{},“args”:}e[0m

2022-05-11 14:05:42.005 +0200 [debug] (e[34mdata-util.jse[0m) e[31mRead {“version_details”:{“cli”:{“deprecated”:{“version”:"<8",“message”:"This FDK version will be deprecated by August 31, 2022. There will be no further feature updates to this version. For a seamless app building experience, ensure to move to the latest FDK version. For more information, see https://community.developers.freshworks.com/t/5433."},“forced”:{“version”:“7.0.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk-7.0.0.tgz -g”,“message”:“Your FDK version has been forced updated to v7.0.0, please visit FDK v7.0 - Announcing Node.js v12 and ES6+ support to know more”},“latest”:{“version”:“8.2.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk.tgz -g”,“message”:"For Freshservice, you can now build apps that use Entity Storage - Custom Objects. For more information, check out the documentation at Entity storage-Custom objects. For a demonstration of this feature, check out the sample apps at https://github.com/freshworks-developers/custom-objects-samples."}},“addon”:{“version”:“1.10.2”,“url”:“https://dl.freshdev.io/cli-addon/addon-1.10.2.zip"}},“last_updated”:{"time_stamp”:1652170366423}}e[0m

2022-05-11 14:05:42.005 +0200 [debug] (e[34mupdater.jse[0m) e[31mlast check more than an day ago, looking for updates againe[0m

2022-05-11 14:05:42.138 +0200 [debug] (e[34mupdater.jse[0m) e[31mdownloaded update manifest as {“cli”:{“deprecated”:{“version”:"<8",“message”:"This FDK version will be deprecated by August 31, 2022. There will be no further feature updates to this version. For a seamless app building experience, ensure to move to the latest FDK version. For more information, see https://community.developers.freshworks.com/t/5433."},“forced”:{“version”:“7.0.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk-7.0.0.tgz -g”,“message”:“Your FDK version has been forced updated to v7.0.0, please visit FDK v7.0 - Announcing Node.js v12 and ES6+ support to know more”},“latest”:{“version”:“8.2.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk.tgz -g”,“message”:"For Freshservice, you can now build apps that use Entity Storage - Custom Objects. For more information, check out the documentation at Entity storage-Custom objects. For a demonstration of this feature, check out the sample apps at https://github.com/freshworks-developers/custom-objects-samples."}},“addon”:{“version”:“1.10.2”,“url”:“https://dl.freshdev.io/cli-addon/addon-1.10.2.zip”}}e[0m

2022-05-11 14:05:42.140 +0200 [debug] (e[34mdata-util.jse[0m) e[31mRead {“version_details”:{“cli”:{“deprecated”:{“version”:"<8",“message”:"This FDK version will be deprecated by August 31, 2022. There will be no further feature updates to this version. For a seamless app building experience, ensure to move to the latest FDK version. For more information, see https://community.developers.freshworks.com/t/5433."},“forced”:{“version”:“7.0.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk-7.0.0.tgz -g”,“message”:“Your FDK version has been forced updated to v7.0.0, please visit FDK v7.0 - Announcing Node.js v12 and ES6+ support to know more”},“latest”:{“version”:“8.2.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk.tgz -g”,“message”:"For Freshservice, you can now build apps that use Entity Storage - Custom Objects. For more information, check out the documentation at Entity storage-Custom objects. For a demonstration of this feature, check out the sample apps at https://github.com/freshworks-developers/custom-objects-samples."}},“addon”:{“version”:“1.10.2”,“url”:“https://dl.freshdev.io/cli-addon/addon-1.10.2.zip"}},“last_updated”:{"time_stamp”:1652170366423}}e[0m

2022-05-11 14:05:42.143 +0200 [debug] (e[34mdata-util.jse[0m) e[31mRead {“version_details”:{“cli”:{“deprecated”:{“version”:"<8",“message”:"This FDK version will be deprecated by August 31, 2022. There will be no further feature updates to this version. For a seamless app building experience, ensure to move to the latest FDK version. For more information, see https://community.developers.freshworks.com/t/5433."},“forced”:{“version”:“7.0.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk-7.0.0.tgz -g”,“message”:“Your FDK version has been forced updated to v7.0.0, please visit FDK v7.0 - Announcing Node.js v12 and ES6+ support to know more”},“latest”:{“version”:“8.2.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk.tgz -g”,“message”:"For Freshservice, you can now build apps that use Entity Storage - Custom Objects. For more information, check out the documentation at Entity storage-Custom objects. For a demonstration of this feature, check out the sample apps at https://github.com/freshworks-developers/custom-objects-samples."}},“addon”:{“version”:“1.10.2”,“url”:“https://dl.freshdev.io/cli-addon/addon-1.10.2.zip"}},“last_updated”:{"time_stamp”:1652170366423}}e[0m

2022-05-11 14:05:42.145 +0200 [debug] (e[34mdata-util.jse[0m) e[31mRead {“version_details”:{“cli”:{“deprecated”:{“version”:"<8",“message”:"This FDK version will be deprecated by August 31, 2022. There will be no further feature updates to this version. For a seamless app building experience, ensure to move to the latest FDK version. For more information, see https://community.developers.freshworks.com/t/5433."},“forced”:{“version”:“7.0.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk-7.0.0.tgz -g”,“message”:“Your FDK version has been forced updated to v7.0.0, please visit FDK v7.0 - Announcing Node.js v12 and ES6+ support to know more”},“latest”:{“version”:“8.2.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk.tgz -g”,“message”:"For Freshservice, you can now build apps that use Entity Storage - Custom Objects. For more information, check out the documentation at Entity storage-Custom objects. For a demonstration of this feature, check out the sample apps at https://github.com/freshworks-developers/custom-objects-samples."}},“addon”:{“version”:“1.10.2”,“url”:“https://dl.freshdev.io/cli-addon/addon-1.10.2.zip"}},“last_updated”:{"time_stamp”:1652170366423}}e[0m

2022-05-11 14:05:42.154 +0200 [warn] e[33m[WARN]e[0m This FDK version will be deprecated by August 31, 2022. There will be no further feature updates to this version. For a seamless app building experience, ensure to move to the latest FDK version. For more information, see FDK v8.0 - Announcing the move to Node.js v14 and ES11 support.

2022-05-11 14:05:42.339 +0200 [debug] (e[34mmanifest.jse[0m) e[31mReloading manifest with {“platform-version”:“2.2”,“product”:{“freshdesk”:{“location”:{“full_page_app”:{“url”:“index.html”,“icon”:“timer.svg”}}}},“whitelisted-domains”:[“https://newaccount1641308742729.freshservice.com”,“https://newaccount1641308742729.freshdesk.com”,“https://newaccount1640944129628.freshdesk.com”,“https://newaccount1640782950379.freshdesk.com”],“engines”:{“node”:“12.22.0”,“fdk”:“7.5.0”}}.e[0m

2022-05-11 14:05:42.340 +0200 [debug] (e[34mmanifest.jse[0m) e[31mInferred db as features.e[0m

2022-05-11 14:05:42.341 +0200 [debug] (e[34mdata-util.jse[0m) e[31mRead {“version_details”:{“cli”:{“deprecated”:{“version”:"<8",“message”:"This FDK version will be deprecated by August 31, 2022. There will be no further feature updates to this version. For a seamless app building experience, ensure to move to the latest FDK version. For more information, see https://community.developers.freshworks.com/t/5433."},“forced”:{“version”:“7.0.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk-7.0.0.tgz -g”,“message”:“Your FDK version has been forced updated to v7.0.0, please visit FDK v7.0 - Announcing Node.js v12 and ES6+ support to know more”},“latest”:{“version”:“8.2.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk.tgz -g”,“message”:"For Freshservice, you can now build apps that use Entity Storage - Custom Objects. For more information, check out the documentation at Entity storage-Custom objects. For a demonstration of this feature, check out the sample apps at https://github.com/freshworks-developers/custom-objects-samples."}},“addon”:{“version”:“1.10.2”,“url”:“https://dl.freshdev.io/cli-addon/addon-1.10.2.zip"}},“last_updated”:{"time_stamp”:1652270742145}}e[0m

2022-05-11 14:05:45.444 +0200 [debug] (e[34mdata-util.jse[0m) e[31mRead {“version_details”:{“cli”:{“deprecated”:{“version”:"<8",“message”:"This FDK version will be deprecated by August 31, 2022. There will be no further feature updates to this version. For a seamless app building experience, ensure to move to the latest FDK version. For more information, see https://community.developers.freshworks.com/t/5433."},“forced”:{“version”:“7.0.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk-7.0.0.tgz -g”,“message”:“Your FDK version has been forced updated to v7.0.0, please visit FDK v7.0 - Announcing Node.js v12 and ES6+ support to know more”},“latest”:{“version”:“8.2.0”,“command”:“npm install https://dl.freshdev.io/cli/fdk.tgz -g”,“message”:"For Freshservice, you can now build apps that use Entity Storage - Custom Objects. For more information, check out the documentation at Entity storage-Custom objects. For a demonstration of this feature, check out the sample apps at https://github.com/freshworks-developers/custom-objects-samples."}},“addon”:{“version”:“1.10.2”,“url”:“https://dl.freshdev.io/cli-addon/addon-1.10.2.zip"}},“last_updated”:{"time_stamp”:1652270742145}}e[0m

2022-05-11 14:06:08.446 +0200 [debug] (e[34mpack.jse[0m) e[31m’pack’ called with {}e[0m

For the transition to FDK8, I have the same concern. Unable to generate application. in addition, my requests no longer accept my header (another post on the forum) on the FDK8 version

Thanks for the update, @aliweb88. I’ll coordinate with our engineering team to help debug this.

1 Like