How to hide/disable custom properties in freshchat?

image

When I tried to hide the “sample” property it returns

image

Am I missing something?

Hi Benny,

For custom properties you need to append cf_ before the attribute name. For example, if your custom attribute name is sample then it should be cf_sample.

Hope this helps.

1 Like

Hi @Mughela_Chandresh,

I tried that, but nothing.

image

Still, it throws this error.

Hi Benny,

For freshchat, I guess we need to append user before the property name. Did you try like this?

await client.interface.trigger("show", {id: "userCustomProperties"})
1 Like

Hi @Mughela_Chandresh,

Yes, we did.

But it throws the same error.

Hi Benny,
please try to get the field name from data method or make api request to get the field names

Hi @Kavin,

Yes, we tried that one too.

But still, it throws the error.

We can hide/disable the default fields email but can’t hide/disable the custom fields.

Please, let us know whether it is feasible or not.

Hi @Mughela_Chandresh,

Is there any update on this topic?

Hi @Bene_Immanuel ,

Are you trying to hide a specific user custom property? or The entire userCustomProperty section itself?

The documentation mentioned of userCustomProperties actually hides the entire section. I tried out testing this out:

If you are looking at individual user custom property, I am not sure of it’s possibility, let me check and come back.

Hi @Saif thanks for the response. It’s specific field values we’re looking to hide, not the whole section. This is currently possible in Freshdesk, could we possibly raise with Krutishkumar Venkataraman?

We appreciate your follow-up, @Jack_Lyle.

@Saif, please take this forward.