How update App works

Hello,

I want to ask about how the update flow Freshdesk App works. I have a custom app and I deploy the new version. As can be seen from the picture, the two versions are both Internally Live, which is quite confusing.

Example: I have an App with 3 versions: 1, 2, 3. Version 2 and version 3 are internally live
It seems to me that the user has to update from version 1 to version 2 first, then they can update from version 2 to version 3, but they can’t update directly from version 1 to version 3.
If I want to update from version 1 to version 3, I have to add version 4, so that version 2 and version 3 are Internally Live. Are these expected behaviors?

Moreover, there are two sites to Add New Apps and Update New Versions, which makes me very confused. Which page should I use?


Finally, is the update flow of the Custom App similar to App Marketplace?

Thank you,
Nhat Nguyen

Hi @Nhat_Nguyen

Hope you are safe.

When we update an app, the app will directly be updated to the latest version irrespective of n number of intermediate versions.

For example :

  1. you publish version 1 of an app and install it in the gallery
  2. you publish version 2 and version 3 for the same app
  3. an update option will be shown near the app in the custom apps section
  4. once you update the app, the app will be directly be updated from version 1 to version 3 (latest version).

Also, we have app management portal 2.0 for the app management process. You can use it to submit the apps as the old portal will be deprecated in the future.

App management portal 2.0 (https://developers.freshworks.com/account) :

Hope this is clear. If you still have doubts please feel free to ask.

Thanks and Regards,
Mughela Chandresh

1 Like

Hello, today I am trying to use the following page to update my custom freshdesk app:

This is the first time I’ve seen this updated UI - previously I always used the old version. Pressing “Add new version” doesn’t do anything - how do I update my application?

While this still isn’t working in Chrome, I switched to Safari and it seems to be working there. :woman_shrugging:

Hi @Caitlin

Can you please open the network tab and click on “Add new version” button and share the HAR logs with us for further debugging?

Thanks and Regards,
Mughela Chandresh