Can't pack app using React and antd lib

app.zip (6.8 MB)
Hey guys.
I’m trying to build an app in freshsales using react.
For the UI I’m trying to use Antd
Running locally it renders the app normally, but I can’t pack the app.
When I call fdk pack, after a while it just returns with no error.
The logs from .logs does not shown anything as well.
I was able to identify so far that commenting some components like Modal and Layout makes the pack works.

So, I would like to know, is there some limitation about libs we can use?
Is there some way to identify what’s causing the issue when it happens?

App is attached.

Thank you for sharing the app @samuelpares

I took your app and digged deeper into what module could be causing this packing issue. I suspect there’s bundle generated by react is throwing about 2000+ warnings (which fdk should not) causing validation module within fdk to behave differently. I will report this to engineering team.

But I’ve found myself able to pack the app successfully by skipping the validation temporarily using following command

fdk run --skip-validation lint

I see you are working with Freshsales and App renders on full page placeholder which can only be testing by uploading it as custom app. Hoping this could temporarily help you continue your app development meanwhile.

1 Like

Hi @Saif!
It worked, I was able to pack the app.
Yeah, not being able to test the full page app is a huge setback, but it worked publishing in the account.
Thank you.

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.