"Error 400: Out of traffic" when making API requests

Hi,

We have an integration with Freshservice which is available on your Marketplace. We make use of the v2 API to sync data from our product to Freshservice.

We have been seeing since December 23, 2020, the following error on some requests:
Error 400: Out of traffic

This happens on different API endpoints (e.g. /api/v2/applications/[id], /api/v2/applications/[id]/installations, /api/v2/asset_types).

I searched Google and the forums, but did not find any mention of the “Out of traffic” error.

What is the cause of this error? Should our integration be handling this error (e.g. wait and retry)?

Thanks

1 Like

Hi Chris. Welcome to the community :wave:

Can you share me the code snippet of how you are making these requests, so that I have a better understanding

@Chris_Scaglione - We worked with Freshservice to investigate into this issue. Appears like this case is highly unusual. I order to solve this, we would need more details which cannot be disclosed on the public thread. Allow me to send you an private message to proceed with next steps…

1 Like

@Chris_Scaglione

Thank you for the information that you have provided over private message, Freshservice team :freshservice: have identified it as edge case and have planned a fix towards the end of this week. There no action required from your end.

1 Like

Hi @Saif,

Thank you!

:freshservice: team has picked up this topic on priority and have stated the fix is live.

Future developers shouldn’t ideally see this issue happening.

Thank you for your patience.

1 Like

Thanks @Saif for getting this fixed!

2 Likes