NPM doesn't support Node v14 issue

hey I’m trying to set up a team to develop a custom app but the version of Node.js that it asks for the installation marks me as obsolete to use with its freshwork CLI
I am going to use Visual studio 2019

Hi Maria,

I think you may need to update your version of npm. Check which version you are running by executing ‘npm -v’.

For node.js version 14.13.0 you need to be on npm version 6.14.8 or above. If your npm version is lower than you need run ‘npm install npm@latest -g’

for the latest version of the Freshworks FDK CLI you need to have your system set to use version 14.13.0. You can check what version of node.js you are set to use with this command ‘node -v’. If its is not version 14.13.0 then you need to install that version with this command ‘npm install -g node@14.13.0’

It is possible to have multiple versions of node.js installed but you can only use one at a time by default. To make sure you are using the correct version for the FDK CLI, enter this command ‘nvm use 14.13.0’

Run all the commands above as Administrator otherwise I have found npm can be a bit unpredictable.

Hope this helps.

2 Likes

Hey Rob thanks a lot ! just to let you know that we had to change some parameters but we finally were able to install everything to make the custom app

Really appreciate your help
Thanks and regards

P

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.